Мар 272011
 

Дома при обновлении пакетов вышла такая ошибка.

# portupgrade -arR
--->  Upgrading 'kdelibs-4.5.5_1' to 'kdelibs-4.6.1' (x11/kdelibs4)
--->  Building '/usr/ports/x11/kdelibs4'
===>  Cleaning for kdelibs-4.6.1
===>  kdelibs-4.6.1 conflicts with installed package(s): 
      kdebase-runtime-4.5.5
      They will not build together.
      Please remove them first with pkg_delete(1).
*** Error code 1
Stop in /usr/ports/x11/kdelibs4.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade20110326-10649-13sngo-0 env UPGRADE_TOOL=portupgrade UPGRADE_PORT=kdelibs-4.5.5_1 UPGRADE_PORT_VER=4.5.5_1 make
** Fix the problem and try again.
--->  Skipping 'deskutils/kdepimlibs4' (kdepimlibs-4.5.5_2) because a requisite package 'kdelibs-4.5.5_1' (x11/kdelibs4) failed (specify -k to force)
--->  Skipping 'net-p2p/libktorrent' (libktorrent-1.0.5) because a requisite package 'kdelibs-4.5.5_1' (x11/kdelibs4) failed (specify -k to force)
--->  Skipping 'russian/kde4-l10n' (ru-kde-l10n-4.5.5) because a requisite package 'kdelibs-4.5.5_1' (x11/kdelibs4) failed (specify -k to force)
--->  Skipping 'x11/kdebase4-workspace' (kdebase-workspace-4.5.5_1) because a requisite package 'kdepimlibs-4.5.5_2' (deskutils/kdepimlibs4) failed (specify -k to force)
--->  Skipping 'net-p2p/ktorrent' (ktorrent-4.0.5_1) because a requisite package 'libktorrent-1.0.5' (net-p2p/libktorrent) failed (specify -k to force)
--->  Skipping 'x11/kdebase4' (kdebase-4.5.5) because a requisite package 'kdelibs-4.5.5_1' (x11/kdelibs4) failed (specify -k to force)
--->  Skipping 'x11/kdebase4-runtime' (kdebase-runtime-4.5.5) because a requisite package 'kdelibs-4.5.5_1' (x11/kdelibs4) failed (specify -k to force)
--->  Skipping 'x11/kde4' (kde4-4.5.5_1) because a requisite package 'kdebase-4.5.5' (x11/kdebase4) failed (specify -k to force)
** Listing the failed packages (-:ignored / *:skipped / !:failed)
        ! x11/kdelibs4 (kdelibs-4.5.5_1)        (unknown build error)
        * deskutils/kdepimlibs4 (kdepimlibs-4.5.5_2)
        * net-p2p/libktorrent (libktorrent-1.0.5)
        * russian/kde4-l10n (ru-kde-l10n-4.5.5)
        * x11/kdebase4-workspace (kdebase-workspace-4.5.5_1)
        * net-p2p/ktorrent (ktorrent-4.0.5_1)
        * x11/kdebase4 (kdebase-4.5.5)
        * x11/kdebase4-runtime (kdebase-runtime-4.5.5)
        * x11/kde4 (kde4-4.5.5_1)

нужно посмотреть для начало файл /usr/ports/UPDATING
в нем мы найдем такую запись.
cat /usr/ports/UPDATING

# pkg_delete -f kdehier4\* kdebase-runtime-4\* kdebase-workspace-4\*
  # pkg_delete -f kdeedu-4\* kdeutils-4\*
  # portmaster -a

делаем как написано.
все получиться!

 Leave a Reply

(required)

(required)

39 Запросов к базе. 0,391 Генерации страницы, 37MB Использование памяти.
Вы зашли с IP: 54.225.16.10