Мар 132011
 

Люблю музыку слушать в соц. сетях.

echo"linux_enable="YES"" >> /etc/rc.conf
serv0# cat /etc/sysctl.conf | grep linux
compat.linux.osrelease=2.6.16

Подгружаем поддержку linux
kldload linux
Добавляем поддержку в make.conf

serv0# tail -n5 /etc/make.conf
OVERRIDE_LINUX_NONBASE_PORTS= f10
OVERRIDE_LINUX_BASE_PORT= f10
LINUX_DIST_SUFFIX= -f10

теперь указываем в /etc/fstab

linproc 		/usr/compat/linux/proc   linprocfs   rw  0 	0
linsys  		/usr/compat/linux/sys    linsysfs    rw  0      0

И теперь ставим порты.

serv0# cd /usr/ports/emulators/linux_base-f10 && make install clean
serv0# cd /usr/ports/www/firefox && make install clean  #на данный момент версия 3.6.15
serv0# cd /usr/ports/www/firefox-i18n/ && make install clean
serv0# cd /usr/ports/www/linux-f10-flashplugin10 && make install clean
serv0# cd /usr/ports/www/nspluginwrapper && make install clean

Теперь от какого пользователя будет запускатсья огнелис проделываем следующее:
Создаем диретокрию для плагина.

$ mkdir -p ~/.mozilla/plugins

И делаем симлинк

$ cd ~/.mozilla/plugins && ln -s /usr/local/lib/npapi/linux-f10-flashplugin/libflashplayer.so

Ставим теперь.

$ nspluginwrapper -v -a -i

Проверяем about:plugins

У меня выходила такая ошибка.

===>  linux-f10-flashplugin-10.0r45 bsd.linux-apps.mk test failed: The component openldap is not defined for LINUX_DIST_SUFFIX= (the corresponding variable openldap_FILE is not defined). This usually means that the current port should be used with non default linux base and/or infrastructure port(s).
*** Error code 1

Для этго нужно проделать выше указанное.
Добавляем поддержку в make.conf

serv0# tail -n5 /etc/make.conf
OVERRIDE_LINUX_NONBASE_PORTS= f10
OVERRIDE_LINUX_BASE_PORT= f10
LINUX_DIST_SUFFIX= -f10

Вот и все.

 Leave a Reply

(required)

(required)

35 Запросов к базе. 0,366 Генерации страницы, 36MB Использование памяти.
Вы зашли с IP: 54.198.210.67